ssh2-php-requirements-4

  • Installing/Configuring
  • Requirements

  • Requirements
  • Requirements

    Requirements

    The » OpenSSL and » libssh2 libraries are required.
    Ensure that the development libraries are installed, where a
    typical package name might be openssl-dev.

    Version 1.2 or newer of the libssh2 library is
    required, although it’s possible newer releases of pecl/ssh2 may
    require newer versions (see the release notes).

    The ssh2_auth_agent() function will only be
    available with libssh >= 1.2.3.

    support for stream_set_timeout() to channel streams will
    only be available with libssh >= 1.2.9.

    Libssh2 comes in two flavours: gcrypt or openssl.
    Some linux distributions build libssh2 with the gcrypt library,
    some use openssl. Libssh2 has some issues when compiled with
    gcrypt, please use openssl.